Android running version 8.5.1 crashing

Incident Report for Careflow Connect

Resolved

A new release, 8.5.2, is available for download to address the crashing issue.
Posted Sep 08, 2025 - 08:12 BST

Update

A fix for the app crashing when trying to load a team has been developed. Please be patient while this is uploading to the play store
Posted Sep 05, 2025 - 12:40 BST

Identified

We are aware of an issue where users may experience the app crashing when trying to load a team. This has been picked up by development and is under investigation
Posted Sep 03, 2025 - 16:02 BST
This incident affected: Mobile Apps (Android App) and Android App.