Web Maintenance

Incident Report for Careflow Connect

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 13:39 BST

Monitoring

We are performing routine maintenance. We don't anticipate any disruption, but if you do experience any issues, they should be resolved within a minute or two. Please report any persistent issue to the Careflow support team.
Posted Sep 18, 2025 - 11:59 BST
This incident affected: WebApp.