CareFlow Connect performance issues

Incident Report for Careflow Connect

Resolved

The system is recovering with no performance issues present.
Posted Jun 23, 2025 - 09:22 BST

Update

We are continuing to investigate this issue.
Posted Jun 23, 2025 - 09:09 BST

Update

We are continuing to investigate this issue.
Posted Jun 23, 2025 - 09:06 BST

Investigating

We are currently investigating an issue, users may experience performance issues and a delay in content appearing.
Posted Jun 23, 2025 - 09:04 BST
This incident affected: APIs, WebApp, iOS App, Android App and Mobile Apps (iOS App, Android App).